Provider does not show up in Data Source list in VS 2012

Jun 6, 2012 at 12:48 PM

The provider itself works just fine, but if you try to access it from Server Explorer by adding a new data connection, it doesn't show up while it does on the same machine/config via 2010.

The reason this is an issue, since at first you think you can "code around this" (and you probably can but its a pain) is that if you use the EF Power Tools to do "reverse engineer" entity framework to generate Code First you CANT as again, it doesn't show up.  I'm guessing this might just be a registry setting - anyone have a clue?  If I figure it out (and I have limited time as I'm in a Sprint) I'll certainly post a solution.

Kevin

Coordinator
Jun 7, 2012 at 12:03 AM

I tried just adding registry setting pointing to the dll that VS 2010 uses but that didn't work.  I most likely will need to create a VfpEntityFrameworkProvider.ExtendedProvider.dll for each version of Visual Studio.  I'll try to have this done by the end of the weekend.  In the meantime can't you open the same project in VS 2010 to do the reverse engineering?

Coordinator
Jun 11, 2012 at 12:11 PM

I posted a new build that works with VS2012.