Empty datetime

Feb 6, 2012 at 1:52 AM

I have started playing with VFPEFProvider 0.6.2. It is amazing. I was able to get up and running withing minutes. Only issue I have is I cannot insert value in  datetime field. It is always empty. I just added DateIn property to Product entity in EF code first sample demo.

 public DateTime DateIn { getset; }
 and changed product line to
var product = new Product { Name = productName, Category = food, DateIn =DateTime.Now };
The sample program runs without error but datein field is empty/blank.

How do I fix this?

Thanks again for the great framework.
Coordinator
Feb 6, 2012 at 11:31 AM

Thanks for identifying this issue. 

I was able to recreate this issue so now I just need to track down the source of the problem.  A fix will most likely require a new build.  I'll let you know when I have one ready.

Feb 6, 2012 at 4:23 PM

Thanks for quick response.

I was searching for the issue and found following which indicates it might be a bug in vfpoledb.

http://www.foxite.com/archives/bug-or-what-0000253993.htm

Feb 6, 2012 at 5:12 PM

I just tried on XP machine and it  worked. It is having problem with Windows 7.

Feb 6, 2012 at 5:38 PM

Also works on Windows 2003 server

Coordinator
Feb 7, 2012 at 11:31 AM

Interesting...

Unfortunately, the problem was all me.  I fixed the bug and posted a new build.

Feb 7, 2012 at 3:44 PM

Thanks, I will give it a try tonight.

Feb 8, 2012 at 5:41 AM

You are genius. It worked with Windows 7.

Thanks for taking care of this issue so fast.