Sample for free tables(Solved)

Feb 3, 2012 at 4:39 PM


I was looking for a VFP provider. Thanks to you.

Do you have any sample about using your provider with free tables?

Thanks for help.

Feb 6, 2012 at 12:35 AM

There are really only two things that are different than using the default SQL Server provider.  The first thing is that you need to setup a connection to the data source differently (as can be expected).  The second thing is that the VFP EF Provider will use a Candidate Key as a Primary Key.  This blog post provides a quick walk though using the VFP EF Provider with free tables.

Feb 6, 2012 at 8:13 AM

Thanks Tom

Feb 6, 2012 at 10:53 AM

Hi Tom,

I followed the post but I can't update the model (Update model from database option).

I have this error :

Unable to generate the model because of the following exception: 'An error occurred while executing the command definition. See the inner exception for details. The source contains no DataRows.'.

The VFPOLEDB and the VFP Entity Framework Provider are installed. I'm working on Windows 7 64 bits.

Feb 6, 2012 at 11:27 AM

Can you send me a copy of your project so that I can try to debug the issue?  You can email it to me at

Feb 6, 2012 at 12:39 PM

I'm sorry I don't have the permission to send the client data.

I have only two tables to create a proof of concept of using vfp free tables with entity framework (using of select, insert, update, delete).

The project does not contains any code at the moment but I can send you it if you want.

Feb 6, 2012 at 2:01 PM

Would you be able to send a zapped copy of the tables (and the project)?  I don't need the data... I just need the structure.

Feb 6, 2012 at 2:39 PM

I send you the project and zapped tables asap.


Feb 7, 2012 at 10:02 AM

Hi Tom,

I think I solved the problem.

I tried to compile the source code on my computer.

I've got an error with GACUTIL post build command.

I used this command in command prompt and the error is that I must have administrator rights to use it.

I installed as administrator and now it works fine. I've got my tables.

Feb 7, 2012 at 11:32 AM

Glad to hear that you were able to resolve the issue.