Data source: does not contain VFP Entity Framework Provider (EF6)

Mar 3, 2014 at 7:57 PM
I followed the instructions on your blog post:

I'm not able to see the "VFP Entity Framework Provider (EF6)", nor do I see any VFP related ones there.

My references contain VfpClient and VfpEntityFrameworkProvider.

Using this blog post:

Tells me all is installed and working.
Mar 3, 2014 at 10:06 PM
Did you notice any errors when running the msi? Check to see if there is an entry in your machine.config (C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\machine.config) for VfpEntityFrameworkProvider2. If it isn't there then make sure that you are running the MSI as an administrator and that you have permissions to modify C:\Windows\Microsoft.NET\Framework\v4.0.30319\Config\machine.config.
Mar 3, 2014 at 10:11 PM
It appears one is in there.
<add name="VFP Entity Framework Provider (EF6)" invariant="VfpEntityFrameworkProvider2" description="Entity Framework 6 Provider for Visual FoxPro Data" type="VfpEntityFrameworkProvider.VfpProviderFactory, VfpEntityFrameworkProvider, Version=, Culture=neutral, PublicKeyToken=feace53afe38fe48"/><add name="Visual FoxPro Data Provider" invariant="VfpClient" description=".NET Framework Data Provider for Visual FoxPro" type="VfpClient.VfpClientFactory, VfpClient, Version=, Culture=neutral, PublicKeyToken=78aaa56544ab725d"/>
Mar 3, 2014 at 10:16 PM
What version of Visual Studio are you using? Can you set me a copy of the project ( so that I can verify it is setup correctly?
Mar 3, 2014 at 10:22 PM
I started with VS2012. Then tried VS2013. Both behaved the same way.
Current version was in VS2013. But opens without problems in VS2012.
It's quick enough to do the process again to create it in VS2012, if that is what you'd like.
Mar 3, 2014 at 11:06 PM
I asked because I just verified that the blog steps work with VS2013 and I just wanted to make sure this wasn't a VS2012 issue. You aren't using VS Express are you? Can you check to see if you can find 9A0E8579-9A04-4433-9DB3-2E6B32661322 in your registry?
Mar 3, 2014 at 11:10 PM
That was not found.
I'm using the Professional version of both VS 2012 and VS 2013.
Mar 3, 2014 at 11:19 PM
Sounds like the msi failed on writing the registry settings. Try reinstalling using the command line with Run as administrator: msiexec /i VfpEntityFrameworkProvider.msi /lv msiexec.log. Send me the msiexec.log if you are still unable to see the "VFP Entity Framework Provider (EF6)" option.
Mar 4, 2014 at 2:49 PM
I've sent you the log.
Mar 4, 2014 at 7:59 PM
Here's an update.
Today, I'm not sure what changed, VS 2013 is working. VS 2012 is not.
Mar 4, 2014 at 9:16 PM
Did you install the EF6 tooling for VS2012?
Mar 4, 2014 at 9:54 PM
I have not. I shall try that now.
Mar 4, 2014 at 10:08 PM
It still doesn't work in VS 2012. I've restarted the computer, recompiled the project. Still not working.
Apr 19, 2015 at 1:52 PM
I just found this thread and information from here helped me. Same thing happen to me. After uninstall and reinstalling using the command line with Run as administrator: msiexec /i VfpEntityFrameworkProvider.msi it worked fine.